Symptom
When opening an applicant's profile in the Latest Applicant Workbench the screen goes blank and you can not navigate from the page.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting > Job Requisitions > Select a Job Requisition > Candidates
- Switch to the Latest Applicant Workbench
- Click on any candidate's application > the screen opens as expected for a moment, but then goes blank.
- Only the background of that page is shown
Cause
Misconfiguration of the enum fields on the Job Application Template.
Values are not defined correctly.
Resolution
To resolve this:
Ensure you set the values correctly for enum values for fields like "currency"
Example Only:
<field-definition id="currency" type="enum" required="false" custom="false">
<field-label mime-type="text-plain"><![CDATA[Currency]]></field-label>
<enum-value value="EUR">
<enum-label><![CDATA[EUR]]></enum-label>
</enum-value>
<enum-value value="GBP">
<enum-label><![CDATA[GBP]]></enum-label>
</enum-value>
<enum-value value="USD">
<enum-label><![CDATA[USD]]></enum-label>
</enum-value>
<default-value>USD</default-value>
</field-definition>
See Also
3385791 - New Behaviours introduced in the Redesigned Applicant Workbench - Recruiting Management
What's New Viewer H2 2022 - Enhanced Search Functionality for Redesigned Applicant Workbench
3169372 - How to update the Currency fields options through Manage Templates? - Recruiting Management
Keywords
Redesigned Applicant Workbench, Latest Workbench, Job Application, Error, blank, redirect, frozen, enum, values, currency , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Known Error