SAP Knowledge Base Article - Public

3425912 - Delay sending not working as expected

Symptom

You have defined a delay sending for your campaign and is not working as expected

Environment

  • SAP Marketing Cloud

Reproducing the Issue

Create a Campaign or Drip Campaign and set up a delay sending with a day and time. 

Cause

Delay time is not incremental, and you get unexpected results. 

Resolution

When you are using a delay date and time, the time must be increasing between each action. This Delay sending logic is explained in the following documentation:
https://help.sap.com/docs/SAP_MARKETING_CLOUD/b88f770e4b7c4ecead5477e7a6c7b8f7/1331eca17b5d427d9a26eda86f605567.html

"A campaign is scheduled to run on Monday and Wednesday. The Delay Sending is set to 1 Day and Send at is set to 8.00 a.m.. Let's say the event is triggered on a Tuesday, March 26, 10.00 a.m. After a delay of 1 day, the next email would be sent on Wednesday, March 27, 10.00 a.m. However, this doesn't comply with the specified time of 8.00 a.m., which appears in the past. So, the email is sent on the next specified day at 8.00 a.m, that is on Monday, April 1 at 8.00 a.m."

See Also

Drip campaign documentation:
https://help.sap.com/docs/SAP_MARKETING_CLOUD/b88f770e4b7c4ecead5477e7a6c7b8f7/bc3ad1a71a454371b9065383a27e8305.html

Keywords

Drip campaign, Delay time, Delay sending , KBA , CEC-MKT-CPG-EXE , Campaign execution , How To

Product

SAP S/4HANA Cloud Public Edition 2402