Symptom
You notice that when creating a Service Quote as a copy from the Service Quote ABC and referencing the Service Request EDF, the errors "Incident category ZZZ already assigned" and "Registered product 123 already assigned" are displayed in the UI.
(Where ABC represents the Service Quote ID, EDF represents the Service Request ID, 123 represents the Register Product ID)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the New Business Work Center.
- Go to the Service Quotes View.
- Filter for All Quotes.
- In the search field, search for the Service Quotes ABC. (where ABC represents the Service Quote ID).
- Mark the Service Quote ABC.
- Select Copy button.
- In the New window, select 'Create with Reference' button.
- In the Reference Type field, Select Service Request.
- In the Reference ID, Enter EDF. (where EDF represents the Service Quote ID).
- Select Ok button.
The errors "Incident category ZZZ already assigned" and "Registered product 123 already assigned" are displayed in the UI.
Cause
The Service Quote ABC and Service Request EDF have the exact same data maintained for the Incident Category and Registered Product fields.
Therefore, once the Service Quote ABC is copied all the information maintained for the document is passed to the newly created Service Quote. So when the Service Request is referenced the exact same information is also passed to the new Service Quote causing a conflict in the UI due to the duplicated information being maintained for the same document.
Resolution
This is currently the standard system behavior for this scenario.
In this case as workaround, we kindly recommend to either reference the new Service Quote with a Service Request that has different Incident Category and Registered Product from the Service Quote being copied or remove the information before saving the new Service Quote.
For this process the following steps can be performed in the system:
- Go to the New Business Work Center.
- Go to the Service Quotes View.
- Filter for All Quotes.
- In the search field, search for the Service Quotes ABC.
- Mark the Service Quotes ABC.
- Select Copy button.
- In the new Service Quote, navigate to the General tab.
- Select the Main Information sub tab.
- In the Incident Category field, remove the value maintained and leave the field in blank.
- Select 'Create with Reference' button.
- In the Reference Type field, Select Service Request.
- In the Reference ID, Enter EDF.
- Select OK.
- Select the Account and Affected Product sub tab.
- In the Affected Products section, remove the duplicate Registered Product.
- Select Save.
Service Quote document will be created without any inconsistencies.
Keywords
service quote, quote, service request, copied, copy, create with reference, reference, registered product already assigned, incident category already assigned, registered product, incident category , KBA , AP-CQP-CQ , Customer Quote , How To