SAP Knowledge Base Article - Public

3426260 - E-mail To B2C Channel Lands In Unassociated E-mails

Symptom

E-mail sent to B2C channel goes to Unassociated E-mails with reason "No matching contacts were found"

Environment

SAP Cloud for Customer

Reproducing the Issue

Pre-Requisite: You have maintained the Sender E-mail address as an Individual Customer which is necessary for B2C Scenarios. 
Steps:

  • Go to Customer Work Center
  • Go to Individual Customer view
  • Click on Create '+' button
  • Enter details along with the E-mail address (The Sender E-mail address)
  • Click Save

Send an E-mail to a B2C E-mail channel from the E-mail address which is maintained in the Individual Customer.
You notice that the E-mail lands in unassociated E-mail with reason "No matching contacts were found". 

Cause

You have set up the E-mail forwarding from the E-mail channel "xxx@abc.com" to the B2B Technical E-mail address "cod.b2b.servicerequest@myxxxxxx.mail.crm.ondemand.com" (xxx@abc.com is the Active E-mail channel in customer system and xxxxxx is the tenant ID of the system).

In B2B scenario, the sender E-mail is matched against the active Contacts in the system. If no active contact is found then the E-mail lands in Unassociated E-mail with the reason "No matching contacts were found".

Resolution

Correct the forwarding rule such that the E-mail forwarding from the E-mail channel "xxx@abc.com" is set to the B2C Technical E-mail address "cod.servicerequest@myxxxxxx.mail.crm.ondemand.com".

You may refer the below series of blog Email Response Management in C4C - Part 1 - Cloud ... - SAP Community (Part 1 , 2 and 3) which can help you understand the E-mail channel setup in C4C.

See Also

3307745 - How the B2B and B2C E-mail Party Determination Works

Keywords

B2C , B2B , E-mail , E-mail Channel , No matching contacts were found , unassociated E-mail. , KBA , LOD-CRM-SC-EML , Email , How To

Product

SAP Cloud for Customer core applications all versions