Symptom
You are using OData API Audit Log or SFAPI Audit Log features and you are facing the following message when trying to see the Payloads:
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to OData API/SFAPI Audit Log feature;
- Click on the "..." button (last column) of a line;
- Open the Request Payload or Response Payload tab;
- See the message;
Cause
There are some possible causes:
- API call with failed status scenario: "Enable Payloads in OData API Audit Log for Edit Errors" option not enabled (under Audit Logs Settings);
- API call with successful status scenario: "Enable All Payloads" option not enabled (under Audit Logs Settings);
- If the settings above are correctly set, this means the OData API/SFAPI Audit Log feature has reached the maximum log retention and started to purge the older ones;
Resolution
These are the resolutions for each cause:
- Go to Audit Logs Settings feature > Select the tab for the API protocol being used (OData API or SFAPI) > Enable the "Enable Payloads in OData API Audit Log for Edit Errors" option:
- Go to Audit Logs Settings feature > Select the tab for the API protocol being used (OData API or SFAPI) > Enable the "Enable All Payloads" option (full instructions in the KBA 3141692):
- Expected behaviour. Nothing can be done;
Keywords
Payload is not logged, payload has already been purged, payload, payloads, log, logs, api, odata, sfapi, ce, compound employee, unable, not able, download, see , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT-CE , Compound Employee API , Problem
Product
SAP SuccessFactors HCM Suite all versions