Symptom
'Individual customer' field is not available on creation of Task screen.
This field cannot be enabled using adaptation.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activity work center.
- Go to Task work center view.
- Click on + to create task.
- Individual customer field is not available.
- Go to Adaptation Mode.
- Individual customer option is available.
- Individual customer is grayed out and cannot be enabled on task creation screen.
Cause
Individual customer field is disabled for creation of task in adaptation for a user, who have access to both Account work center and Individual customer work center.
Resolution
To enable access of Individual Customer field on Creation of Task screen, user's access right must be only enabled for Individual Customer work center view and not for Account work center view.
User access restriction settings can be maintained under Administrator work center view.
This is the current and expected behaviour.
NOTE: Field Individual Customer will be enabled on task creation screen, only if user's access rights is enabled for work center for "Individual Customer" work center view and disabled for Account Work center view.
Keywords
Task, Create screen, Individual Customer, field, adaptation, disabled , KBA , LOD-CRM-ACT , Activities , Problem