Symptom
After the integration interface is triggered in HCM side, you expected an email notification to be triggered, which did not happened.
Sometimes, errors inside the logs can be found, similar to the one below:
- delivery temporarily suspended: connect to hr.post.ch[XXX.XXX.XX.XX]:XX: Connection refused)}
Environment
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Interface is triggered
- Reports such as RH_SFI_SYNCHRONIZE_EMPL_DATA may be executed
- Execution is completed
- No email notification was triggered
Cause
No email configured in the User profile for the user used in SuccessFactors for the integration.
Resolution
You need to make sure that the user used in this Integration, inside SuccessFactors, has en email configured to it's profile.
You can use the below KBA to help you identify the user used on this: 2302957 - Why and who gets email notification for an update/upsert in Successfactors system via OData API? - SAP for Me
Once the email is added, the notifications should start flowing.
See Also
Keywords
email, notification, RH_SFI_SYNCHRONIZE_EMPL_DATA, user profile, API user, technical user. , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , Problem