SAP Knowledge Base Article - Public

3427270 - "HTTP Status 404 -Not Found" error when running SAP Cloud Agent in SAC

Symptom

  • When running the SAP Cloud Agent link <host>:<port>/C4A_AGENT/deploymentInfo on the browser, an error appears: "HTTP Status 404 -Not Found" and "The origin server did not find a current representation for the target resource or is not willing to disclose that one exists"
  • SAP Cloud Agent deployment link is not showing the version even after deploying the C4Agent war file correctly.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

  • SAP Cloud Agent
  • SAC Analytics Cloud

Reproducing the Issue

  1. Deploy the SAP Cloud Agent war file in tomcat 'webapps' folder correctly.
  2. Then run the SAP Cloud Agent deployment link <host>:<port>/C4A_AGENT/deploymentInfo on a browser to check the version. 

Notice that it throws the following errors: 

  • "HTTP Status 404 -Not Found"
  • "The origin server did not find a current representation for the target resource or is not willing to disclose that one exists."

Cause

SAP Cloud agent is not supported on tomcat version 10 or higher.

Resolution

  • Either downgrade your standalone Tomcat to a version below 10 or use the Simple Deployment Kit.
  • Refer to the following guide to check the latest version of the Agent and the Tomcat: KBA 3264839 -  SAP Analytics Cloud Agent and Simple Deployment Kit Version Upgrade Information

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud Agent, Tomcat, SAC, C4Agent, version, not found, error , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem

Product

SAP Analytics Cloud 1.0

Attachments

Pasted image.png
Pasted image.png