Symptom
During the usage of the system, you notice that in some circumstances a user session timeout dump is raised.
The dump popup shows the following message:
"400 Session timed out - please log in again"
Environment
SAP Business ByDesign
Cause
There are a couple possible causes for a session timeout in the system:
- The user is inactive in the system for 1 hour.
- The user is using another browser tab with the same tenant in parallel, and closes it. Since the sessions are shared between the tabs, it causes a logoff.
- The user may have been manually logged of by a system administrator through the Key User Settings.
- There is a difference in timeout parameters for Single Sign-On token renewal (only applicable when using a SSO setup).
Resolution
Based on the possible causes mentioned, please check the suggestions below to avoid session timeouts:
- Ensure that the user is not inactive in the system for a prolonged period of time.
- In case parallel operation is required, it is suggested to use the built-in tabs inside the Business ByDesign system itself.
- Please check with administrators for the possibility of a manual logoff.
A manual logoff can be done by an administrator by following the below steps:- Click on the user avatar icon on the top-right of the screen.
- Click on Key User Settings.
- Click on User Session Settings.
- Search for the desired user, and click on the trash bin button.
- Please check with your Identity Provider administrator for token renewal timeout parameters.
See Also
1800435 - Changed frontend behavior due to introduced session-timeout (security)
2941957 - Auto Logoff Time Not Respected When Using Single Sign On
Keywords
session, business user, logoff, error 500 , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , Problem