Symptom
Deletion of sales data is not possible in an account.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers workcenter.
- Go to the Accounts view.
- Open any Account that is replicated from your external system.
- Go to Sales Data facet.
- Edit the account.
- Select the row of an existing sales data.
- In Action Column click Delete.
- Error is witnessed "Deletion of Sales Data is not allowed once Customer is replicated".
Cause
A system with active replication a Sales Data has an entry in replicated external system. Since deletion of Sales Data in external system is not possible, deletion of sales data is also not allowed in C4C.
Resolution
Deletion of sales data is also not allowed in cloud for customer . This is current behaviour.
Following are available options as a workaround.
1) Sales Data entry contains a personalization hidden field 'Marked for Deletion'. Enable this field and set to 'true'. Though the entry is visible in Account, however marked sales data would not be available for transaction in C4C or External system.
2) Sales Data entry is only replicated to external system if all three key fields 'Sales Organization', 'Distribution Channel' and 'Division' are filled.
Keywords
Delete, sales org, sales data, external, replicated, account , KBA , LOD-CRM-ACC , Account , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem