Symptom
You wish to find out why an employe (may be a new employee also) cannot log into BenefitFocus by clicking on the Benefits tile.
An error similar to the ones below may be displayed:
"No sponsor found for successfactors companyid <<companyid>> and bfSSOIdentifier"
OR
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors HCM Suite
Cause
Wrong Configuration:
- Either the Employee's Date of Birth or National ID information is missing.
- There is more than one primary National ID for the employee marked as "Is Primary = Yes."
When the SAP SuccessFactors Identity Provider is configured for SSO login to the BenefitFocus Solution Extension, it uses a special identifier (BFSSOIdentifier). This identifier is a combination of the Employee’s Date of Birth + National ID (or Social Security Number).
Resolution
First, check if the Date of Birth and National ID are properly filled in for the affected employee. Make any necessary adjustments.
Next, verify if the employee has more than one National ID marked as primary. If so, adjust the entries accordingly to ensure only one National ID is set as primary.
NOTE: If the above doesn't work, please reach out to SAP SuccessFactors Support (LOD-SF-INT-CPI-TPI) to try to delete all national ID for the given user (via a compound delete in the DB) then you can add the relevant national ID again.
Keywords
SSN, isprimary, IS PRIMARY, BenefitFocus, BF, Unable to Access BenefitFocus via SAP SuccessFactors, unable to access, access, benefits, benefits tile, cannot log into BenefitFocus, can't logon, cannot logon, The requested operation is not available, 2970fe2cc9ee7dfffef19f213c97170edfb0022a , KBA , LOD-SF-INT-CPI-TPI , Standard SF to 3rd Party Integration using CPI , Problem
Product
Attachments
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SAP Knowledge Base Article - Public