Symptom
When you select the field 'Net value (Transactional Currency)' on the Report Customer Invoice Volume with Price Components the value displayed is not the same amount you see on the Customer Invoice Document.
Environment
SAP Business By Design
Reproducing the Issue
- Go to Customer Invoicing work center.
- Invoice Documents view.
- Search for the ID HJK.
- Click on Open and then the View All button.
- Navigate to the Pricing tab
- Net value is 5.148,00 EUR
- Total amount is 5.301,70 EUR
To see the report information follow the steps below:
- Go to the Business Analytics work center.
- Design Reports view.
- Search for the reports CRMCIVIB_MQ0001 and CRMCIVIPATCB_Q0001.
- Open, view all.
- On each report navigate to the View tab.
If you add the Column Field 'Net Value (Transactional Currency)' the information is not the same for both reports.
In the Report CRMCIVIB_MQ0001 the net value (transactional currency) field is showing the value 5.301,70 EUR.
In the Report CRMCIVIPATCB_Q0001 the net value (transactional currency) field is showing the value 0,00 EUR.
Cause
In the report 'Customer Invoice Volume with Price Components' (Report ID CRMCIVIPATCB_Q0001) the Key Figures Net Value (Transactional Currency) and Total (Transactional Currency) cannot be correctly displayed on Invoice level since for these price components the aggregation does not work as expected.
The system will not accumulate all line items but will just take the first value of the line items.
In the Customer Invoice HJK, the first line item in the report is line item 20. Since line item 20 in HJK is a Sales Kit - Sub Item and does not have a price, the value is displayed as 0,00.
You can also see this by adding the Customer Invoice Item in the Rows of the report and expand the Invoice in the results.
Resolution
This is a system expected behavior.
Keywords
Report, CRMCIVIB_MQ0001, CRMCIVIPATCB_Q0001, Currency, Transactional, Price Components, Volume , KBA , SRD-CRM-ACT , Activities , How To