Symptom
After creating competencies or skills using Talent Intelligence Hub, attempting to map the competencies and skills to a role causes an error:
An application error occurred. Please try again later, or notify support (with the error information of errorId=XX, timestamp=XX, and the version information from the current screen) if the issue keeps occurring.
Environment
- SAP SuccessFactors Talent Intelligence Hub
- SAP SuccessFactors Job Profile Builder
Reproducing the Issue
- Log in to system
- Navigate to Admin Center > Manage Job Profile Content
- In the dropdown, select Set Up Families and Roles
- Select the Roles tab > Select any role
- Select the Mapped Competencies tab > Map Competencies
- Select competencies created in TIH > Map > I'm Done > Save Role
- Receive error
OR
- Log in to system
- Navigate to Admin Center > Manage Job Profile Content
- In the dropdown, select Set Up Families and Roles
- Select the Roles tab > Select any role
- Select skills created in TIH > Map > I'm Done > Save Role
- Receive error
Cause
- Competency data is populated in the en_DEBUG locale
- The JDM > TIH migration was completed and JPB was enabled afterward
Resolution
Competency data is populated in the en_DEBUG locale
en_DEBUG (English (DEBUG)) is currently not supported in Talent Intelligence Hub. The solution is slightly different depending on if you're using data from the en_DEBUG locale.
- If you are not using data from the en_DEBUG locale, the locale data needs to be removed:
- Log in to system
- Navigate to Admin Center > Manage Talent Intelligence Hub
- Select the Attributes tab
- Search for the attribute with the competency type > select the competency
- Select Edit
- Select the globe icon in the upper right-hand corner to open translations
- Select English (DEBUG) > remove all text from the name and description fields > Save
- If you are using data from the en_DEBUG locale, copy the data from en_DEBUG to a different locale and remove the data from en_DEBUG:
- Log in to system
- Navigate to Admin Center > Manage Talent Intelligence Hub
- Select the Attributes tab
- Search for the attribute with the competency type > select the competency
- Select Edit
- Select the globe icon in the upper right-hand corner to open translations
- Select English (DEBUG) > copy all text from the name and description fields
- Select a different locale and paste text from the name and description fields > Save
The JDM > TIH migration was completed and JPB was enabled afterward
NOTE: Customers who migrated from JPB > TIH are not impacted by this scenario since they must complete the JDM > JPB migration and correct all check tool errors anyway. Customers who migrate from JDM > TIH are not required to enable JPB.
Whenever the JDM > TIH migration is completed, the system will sync all TIH data to JDM. However, if JPB is enabled after this migration was already completed, the system will now look to JPB to sync data but the JDM > JPB migration hasn't been completed to resolve data issues.
If JPB was enabled after the JDM > TIH migration, all check tool errors from JDM will need to be corrected. Then the JDM > JPB migration will need to be completed for the system to work correctly. Please follow the steps in 2276692 - Best Practices on Job Description Manager to Job Profile Builder Migration.
Keywords
TIH, attributes, competencies, skills, map, add, job role, role, unable to map competencies, unable to map skills, success factors, sf, sfsf, errors , KBA , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , LOD-SF-TIH-SKL , Skills Ontology , Problem