Symptom
You are trying to open AskHR, you click in the icon and the screen is requesting you for email to login to AskHR, similar to screenshot below:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- ECSC (AskHR)
Cause
You are not using SAP SuccessFactors as identify provider in BTP.
Resolution
To solve this error, you can follow the below steps:
1. In BTP subaccount, remove the exist integration token, and re-create integration token by selecting option: "Use SAP SuccessFactors identity provider".
2. Once the new integration token created, go to BTP subaccount -> Security -> Trust, select tab "Application Identity Provider", choose new generated SAP SuccessFactors identity provider as default.
3. Then login SAP Successfactors company , access -> "Extension Center" and add the new integration token to complete the integration.
4. Then go to "Manage OAuth2 Client Applications", find latest generated item and copy related API key and then paste into BTP subaccount Bizx_Odata destination field "Client Key" and "assertionIssuer".
Once the change takes effect, this error should be resolved.
See Also
Keywords
AskHR login, credentials, email, IdP, Identity Provider, Employee Central Service Center, custom identity provider. , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem