Symptom
Service Catalog field dropdown is empty in Case.
Environment
SAP Service Cloud Version 2
Reproducing the Issue
- Navigate to Cases.
- Open Case 123 (where 123 is Display ID of the Case).
- In Category section, click on the pencil icon and pick a Service Category value.
- Notice that no values are displayed in the dropdown.
Cause
Issue occurs when the Case Type of the Case is using the old version of Service Catalog.
Resolution
Create and activate a Case Type following the below steps which has the latest version of Service Catalog used.
- Go to User Menu.
- Go to Settings.
- Search for Cases.
- Select Case Types.
- Select Case Type ABC (where ABC is an Active Case Type with old version of Service Catalog) and choose Create New Version.
- Under General Settings, select New version of Service catalog in Catalog field.
- Click on Activate.
See Also
You can also refer to this KBA for further details 3426364 - Unable to Delete Service Catalog
Keywords
Service Catalog, Case Type, Empty, Version , KBA , CEC-CRM-SCA , Service Catalog for SAP Sales/Service Cloud , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0