Symptom
You select a signature template in Email and notice that placeholders like {{formattedName}}, {{extensions.Position}} are shown along with your signature instead of being shown as blank.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Cases and open any case.
- Click the "Send email" button.
- Fill out the details in 'From' and 'To' fields.
- From Signature option, select a template.
- You can see in the email, that the signature is shown along with the placeholder (for example - {{extensions.Position}} ).
Cause
This is the system design and not a bug.
Resolution
Placeholder is kept as it is to let the agent know there is an action that needs to be taken at their end.
As a workaround, template can be tweaked using #if condition in HTML code. For example,
{{#if ( eq extensions.Position NULL ) }}
{{formattedName}} <br>
{{else}}
{{formattedName}} {{extensions.Position}} <br>
{{/if}}
As per the above code example, if {{extensions.Position}} placeholder is empty, then only {{formattedName}} is displayed; else both {{formattedName}} and {{extensions.Position}} placeholder values are displayed.
Keywords
Placeholder, empty, blank, Signature Template , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-CZM-DTR , Determination for SAP Sales/Service Cloud , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem