Symptom
You are executing a Payment run and you are getting the following error message: 'Work package ID XYZ system error; report an incident'.
(XYZ represents the Work package ID)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Payables work center.
- Go to Payment Runs subview.
- Select "All Payment Runs".
- Search for Run ID: DEF (DEF represents the Run ID).
- Open the Application Log ID in reference to the run ID DEF.
- You will see the following error message:
'Work package ID XYZ system error; report an incident'.
Cause
One possible reason for this error is because the logic checks for the payment run require that the total amounts of the items being considered have the same direction, either positive or negative (+ / -).
Usually, there are two groups determined for all Business partners, and they do not have the same sign.
The account used is a mixed account, meaning it is both a customer and a supplier account. Additionally, the netting option is scoped in the configuration. This means that relevant payables items are being picked up, but there are also items from the receivables side that are being considered. Since both positive and negative amounts are identified, the issue arises.
Resolution
To resolve this issue, it is recommended to avoid including "mixed" accounts on payment runs. Instead, it is recommended to clear the payables and receivables separately. By doing so, the payment proposal will only include open due items from either the supplier accounts or the customer accounts, but not both. This will ensure that the logic checks for the payment run are satisfied.
See Also
Payment Run, Work package ID, system error, Payables.
Keywords
KBA , AP-DUE , Due Item Processing , How To