Symptom
Filter on activity ( task/appointment/ Phone Call/Visit ) object status does not work on Calendar.
“*Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.*
Environment
SAP Cloud For Customer
Reproducing the Issue
- Open the Calendar work Centre.
- Click advanced filter.
- Select type "Appointments".
- From the various status options available, deselect the option "Complete" status.
- Appointments with status "Complete" should not be seen in Calender.
- Issue: Appointment with completed status seen on Calender.
Cause
Inconsistent record in Customise Colour Coding Configuration, leads to incorrect visibility of Appointments with Completed status on Calendar.
Resolution
Removal of the empty rows from the configuration, will not show Appointments with Completed status on Calendar.
Execute following steps to remove empty rows from the configuration table:
- Go to Administrator work centre.
- Go to General Settings work centre view.
- Click on "Calendar Colour Categorisation" hyperlink.
- Remove empty rows from the Customise Colour Coding Configuration OR select all the empty rows and click on Remove.
- Click on Save.
Keywords
calendar, filter, activity status, custom table, remove, calendar colour categorisation , KBA , LOD-CRM-CAL , Calendar Control , Problem