Symptom
When checking the field Party Role Code within the Ticket screen Advanced Search, you noticed values that are not set as Active, within the Ticket Business Configuration Activity.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service Work center.
- Select the Tickets view.
- Click on the Advanced Search.
- Check the results from the field Party Role Code.
Cause
This is the current standard behavior.
Resolution
The Party Role Code results are based on the underlying DataType APC_V_PARTY_ROLE_CODE and will return all the Party Codes maintained in the system (cross all Business Objects).
It was decided to not filter out the Role code results based on the 'Active' indicator from the Ticket Activity, since there could be documents that were created with a Party role whose 'Active' indicator was deselected or removed from the Ticket Party configuration. This way even those Parties with those obsolete Party roles can be brought up using the Advance Filter.
Any changes to this existing behavior, must be posted in our Influence Page, for further PM Team analysis
Keywords
Wrong Values; Not Fetching; Not Equal; Different; Not Expected , KBA , LOD-CRM-SRP , Service Request Processing , How To