Symptom
Error message upon trying to post a New Manual Clearing:
'ABC is not a contact for DEF'
Remark: the same error message also occurs in Collection Case GHI screen.
ABC represents a Contact ID (Name).
DEF represents the Customer Account ID (Name).
GHI represents a Collection Case ID.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Receivales work center.
- Go to the Customer Accounts view.
- Find respective Account ID and click View
- Select respective Payment open item and Invoice, which is Collection Case GHI.
- Click Clear Manually.
- Enter respective Posting Date and Document Date.
- Click Clear.
- Error is thrown:
'ABC is not a contact for DEF'
Remark: the same error is thrown while opening Collection Case GHI from Receivables work center -> Collection Cases view.
Cause
In Collection Case GHI, the Customer Contact ABC is maintained.
However, ABC is not maintained as a Contact in Customer Account DEF.
Resolution
The Customer Contact assigned to the Collection Case GHI must be also maintained in Corporate Account master data as a Contact (Contacts tab -> Contacts sub tab).
Keywords
collection case; contacts; activity; customer contacts; new manual clearing , KBA , SRD-FIN-MOP , Payment Management , How To