SAP Knowledge Base Article - Public

3430672 - Unable to revert back to the default identity provider for SAP Analytics Cloud.

Symptom

  • Custom SAML enabled on the SAC with the desired email ID format.
  • Desired format for the SAML: The email ID of the IT contact person/system owner is firstname.lastname@abc.com but for SAML the desired email is f.lastname@abc.com.
  • Want to revert back to the default IdP.
  • Cannot find the SAC details with the email mentioned in the SAC using f.lastname@abc.com.

Environment

SAP Analytics Cloud FPA Version: 2023.21.16
 
 

Reproducing the Issue

  1. Log in to the IdP admin tool using the email ID of the system owner in SAC.
  2. Cannot find the SAC details to revert back to the default IDP.

Cause

The email ID in SAC does not match with the email ID in default IdP.

Resolution

  • System owner cannot see the SAC details in IdP admin tool because the user's email ID coming from custom IDP is different than the one which the SAC uses with default IdP.
  • Use the correct email ID to log in to the IDP admin tool to get the SAC details and then can revert back to the default IDP.
  • For correct email ID you can reach to the SAP support raising an incident in the component LOD-ANA-AUT.

See Also

Keywords

SAC, IdP, custom SAML, email , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0