SAP Knowledge Base Article - Public

3430773 - PR workflow is not restarting after manually cancelling the workflow.

Symptom

  • Purchase requisition not restarting after cancelling the workflow manually using the administration application.
  • Purchase requisition is 'In Process" status, and workflow never restarts.

Environment

SAP S/4HANA Cloud.

Reproducing the Issue

  1. Open Workflow Administration application.
  2. Select the workflow instance.
  3. Click on "Cancel" button.
  4. Restart the PR workflow.

Cause

Field has no impact on the workflow either via Restart BADI or through SSCUI defined fields for restart.

Resolution

To maintain the fields for which restart of workflow is applicable, use the configuration step Manage Conditions to Restart Flexible Workflow in Manage Your Solution app/you can create an implementation in Definition of Conditions to Restart Flexible Workflow in Purchase Requisitions (MM_PUR_S4_PR_WFL_RESTART) in the Custom Fields App and Custom Logic App. If you make a restart-relevant change in a purchase requisition in Awaiting Approval status without an active workflow instance, the workflow starts again.

See Also

Manage Workflows for Purchase Requisitions | SAP Help Portal

Keywords

S4_PC, PR, purchase, requisition, workflow, restart, in process , KBA , MM-PUR-GF-REL , Release (Approval) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions