Symptom
You've noted that the User checked in and out Visit at 10:30:00.000Z and 11:00:00.000Z, respectively, however the Check-In time in C4C is 16:00:00.000Z.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Visits
- Open Visit ID: XYZ ( XYZ stand for the Visit ID)
- Go to the Changes Tab
- Observe: Check-In time in C4C is 16:00:00.000Z
Cause
- The time format will reflect the users time as in his/her Time Zone setting.
- The Visit was created in offline and before syncing to online the visit was checked-in and checked-out and the same date got updated.
Resolution
- Unlike check-in and check-out date ,the Created-on date will get updated only after the sync. Therefore make sure that the visits created in offline are synced before check-in and check-out.
- The time format will reflect the users time as shown in the User Profiler Time Zone setting.
- In the Visit XYZ, the timestamps shows as below:
StartDate Time: 2024-02-05T10:30:00.000Z
EndDate Time: 2024-02-05T11:00:00.000Z
Check-InDate Time: 2024-02-05T10:30:00.000Z
Check-OutDate Time: 2024-02-05T11:00:00.000Z
All times are in UTC. meaning that 10:30:00.000Z UTC will show 16:00 , in India if the Time Zone Offset is UTC +5:30 for the user.
Keywords
KBA , LOD-CRM-ACT-VST , Visit Planning , How To
Product
SAP Cloud for Customer core applications 2311