SAP Knowledge Base Article - Public

3430876 - [Onboarding] E-Verify encountered data errors. Please contact Product Support

Symptom

  • When submitting a case to E-Verify, the following error is being encountered: "E-Verify encountered data errors. Please contact Product Support with the following error details: case_creator_email_address: Invalid value for "case_creator_email_address", must conform to the pattern /^.+@([a-zA-Z0-9]+(-[a-zA-Z0-9]+)*\.)+[a-zA-Z]{2,}$/."
  • Backend logs identify the email address that's causing the issue: 

    Caused by: com.successfactors.onb2compliance.service.everify.client.ApiException: {"errors":[{"error_code":"ATTRIBUTE_FORMAT","attribute_name":"case_creator_email_address","message":"Invalid value for \"case_creator_email_address\", must conform to the pattern /^.+@([a-zA-Z0-9]+(-[a-zA-Z0-9]+)*\\.)+[a-zA-Z]{2,}$/.","value":"Peter.Parker@spiderman.com "}]}

 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to SAP SuccessFactors HCM > Proxy as assigned user who needs to submit E-Verify activity
  2. From Home page click on Compliance tile > select impacted candidate
  3. Click Submit
  4. Error is received: "E-Verify encountered data errors. Please contact Product Support with the following error details: case_creator_email_address: Invalid value for "case_creator_email_address", must conform to the pattern /^.+@([a-zA-Z0-9]+(-[a-zA-Z0-9]+)*\.)+[a-zA-Z]{2,}$/."

Cause

Submitter’s Email Address in Compliance settings does not match required criteria, has a typo (i.e. upper case) or a blank space before or after the email address.

Resolution

  1. Go to Compliance settings > United States > E-Verify
  2. Next to the default company ID, under Actions, click the pencil icon
  3. Correct the email address under Submitter’s Email Address so that it matches the email address saved in the user's employee profile (check for upper / lower case) and make sure no blank spaces before or after email > click Save
  4. Submit E-Verify again

Keywords

E-Verify, invalid email, case creator, submitter's email address, Compliance settings , KBA , LOD-SF-OBX-EVF , Everify , How To

Product

SAP SuccessFactors Onboarding all versions