Symptom
When using Manage Templates, a 504 error (Gateway Timeout) is received or the page continuously loads when performing one of the following actions:
- Selecting field permissions
- Selecting fields defined
- Making a change to fields defined
Error messages received include the following:
- errorId=null, timestamp=null, errorName=dwr.engine.http.504
- Unable to access this template through Manage Templates at this moment. Alternatively, you can manage templates through Provisioning, or contact Product Support for further assistance.
NOTE: This issue is not limited to any Recruiting template type. Offer Detail, Candidate Profile, Job Application, and Job Requisition templates are affected.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Scenarios facing this issue:
Selecting Field Permissions:
- Go to Admin Centre.
- Go to Manage Templates.
- Select Recruiting Management.
- Select a Job Requisition, Application, or the Candidate Profile template.
- Select "x Field Permissions defined..."
- Page loads permissions does not load.
Selecting fields defined
- Go to Admin Centre.
- Go to Manage Templates.
- Select any template type.
- Click on “x fields defined…”
- Receive the error after a little while
Making a change to fields defined
- Go to Admin Centre.
- Go to Manage Templates.
- Select any template
- Open “Field Defined”
- click “Add” at the bottom and try to add something there
- the page load for many seconds and then time-out message (error 504)
Cause
Issue is caused by the following feature being enabled:
As a result of the setting being enabled the following scenario occurs:
The template is sent to for security scan.
However due to the nature of the scan tool used it takes the entire template and all affiliated fields with picklists and objects to check for entries in translations.
This in turn takes time and in some instances longer than 120 seconds, which is the UI limit for waiting before timeout.
As a result, the page does not action what was added/changed even though the security scan runs.
Resolution
At the moment this scenario occurs to templates of roughly more than 50 fields and with numerous picklist and object fields.
As a workaround, Support will upload templates on behalf of customers with the security setting enabled and with large templates experiencing this issue.
Please note if you have an implementation partner this should be directed to them.
Please follow the steps below found in the corresponding KBA to request SAP SuccessFactors Recruiting Management Support Team to upload your XML template on your behalf:
2258199 - SAP SuccessFactors Recruiting - Provisioning Configuration Changes
XML Template Upload due to Manage Templates limitation |
As of today, Manage templates does not offer all same capabilities as uploading XML templates directly from the back-end. If you try to perform an action and it is not available in Manage Templates, you can raise a ticket to the SAP Support team to upload a new template version. When opening the support ticket, please provide the acceptance form that can be downloaded from the link below and the new XML version. The support team will not make the change or review it, support will only upload a new template version that needs to be provided by the customer. If the template contains any error and upload is not possible, the error information will be provided back to the customer and the ticket will be closed, it is the customer's responsibility to review the changes and ensure the XML template has no issues when uploading if the customer still needs help to overcome the error a partner needs to be engaged as the support team is not able to provide guidance on custom changes. Required: The limitation in Manage Templates must be declared else this request will be rejected. Limitation must be valid, if a required entry in Manage Templates is trying to be avoided this is not a limitation. Note: Always perform the change first in a test/dev environment, run some tests related to the change to ensure it will not have any negative impact. Please download form here |
See Also
KBA 2258199 - SAP SuccessFactors Recruiting - Provisioning Configuration Changes
Keywords
RCM-124881, WEF-134663, manage, templates, slow, performance, scan, user, input, upload, xml, requisition, application, candidate, offer, 504 Gateway Timeout , KBA , LOD-SF-RCM-SYS , System Performance, Usability, Errors, Security , Problem