Symptom
When creating a Purchase order with account assignment category 'R' in the 'Manage Purchase Orders' or 'Create Purchase Orders - Advanced' APPs.
The system is raising error message, 'Service order item SC1/****/000100 does not exist.' (CRMS4_DATA_EXCH009)
Environment
SAP S/4Hana Cloud
Reproducing the Issue
- Go to app "Manage Purchase Order"
- Click on "Create" to create a new purchase order
- Enter the mandatory data
- Create a line item choosing Account Assignment Category 'R' (Service Order)
- In the account assignment tab choose Service Doc.Type 'SC1'
- Enter a valid Service Document number and item and click "Apply"
Even although the service document details are valid, the error message is raised "Service order item SC1/****/000100 does not exist"
Cause
Service contracts are not supported as account assignment objects in purchase orders, only Service Orders of document type SVO1 can be used currently.
Resolution
With Account Assignment Category 'R' use service order type 'SVO1'.
Keywords
FCO_SRVDOC004, CL_FCO_SRVDOC_DAO, fco_srvdoc, T163K, OME9, SC1, CRMS4_DATA_EXCH009, CRM_ORDERADM_H_GUID_GET_DB, CL_CRMS4_LOGINT_UTIL, Method CHECK_SRV_ORDER_VALID, crms4d_btx_h , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , MM-PUR-PO , Purchase Orders , MM-FIO-PUR-PO , Fiori UI for Purchase Orders , Problem