Symptom
An incorrect account (supplier instead of customer or vice versa) is determined for interpretation algorithm 001 while bank statement processing. This sometimes results in posting the subledger document to wrong account or raising the error message "Account type K is not defined for document type DZ" or "Account type D is not defined for document type KZ."
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Access the app Reprocess Bank Statement Items.
- Provide the filters to find the bank statement items
- Click on Reprocess.
- Check the log under the tab Log.
Cause
Providing general values/non-unique values in the memo line results in determining the wrong account.
Resolution
Please be informed that providing general values in the memo line will reduce the chance of automatically processing the bank statement.
SAP always recommends providing unique values in the reference document number field to enable the successful processing of bank statements. The non-unique values in the field can lead to such scenarios where an unexpected journal entry is selected for clearing and failure in the bank statement processing.
Please refer to the KBA 2979670 - Upload bank statement without entering number intervals causes error The difference is too large for clearing and maintain the number range interval. This will increase the chances of determining the documents to be cleared correctly.
In the SAP Help Portal Documentation, it is explained in detail how to maintain the number range interval under the description for standard algorithm 001.
See Also
Keywords
Reprocess, Supplier, Customer, wrong account type, incorrect account type, Reprocess Bank Statement Items, F001, 001, standard algorithm, memo line, S4_PC, S4_1C, FI-BL-PT-BA, Account type K is not defined for document type DZ, F5243 , KBA , FI-BL-PT-BA-2CL , bank statement (Public Cloud) , FI-FIO-AR-2CL , Fiori UI for Accounts Receivable (Public Cloud) , Problem