Symptom
Since the 2402 upgrade, there has been an e-mail validation for Ticket Interactions. However, when you enter an invalid e-mail address in the To field and click send, you see a successful message instead of an error messages.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center
- Go to the Tickets view
- Open the Ticket 123 (Where 123 refers to the Ticket ID)
- Go to the Timeline or Interactions tab
- Click New E-mail
- Type an invalid e-mail address in the To field (e.g. test@a)
Result: There is a message for "Email sent successfully."
Expected Result: There are error messages. One is "Email was not sent due to error(s)." and another one is "Email address test@a is invalid."
Cause
With the 2402 upgrade, only the standard validation is implemented. Therefore, test@a is not recognised as an invalid e-mail address, however, when @ is missing in the e-mail (e.g. test), then you see error messages.
Resolution
You need to implement VALIDATE_RECIPIENT_EMAIL BAdI for the Email Validation.
See Also
Keywords
ticket, interaction, e-mail, email, validation, domain, incorrect, wrong, VALIDATE_RECIPIENT_EMAIL, 2402 release , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-INT , Ticket Interactions , Problem