Symptom
When sending the Mass Offer for Approval - the system throws error “An error occurred while saving your changes. Contact your system administrator” with no information about what is causing the error.
The issue occurs for only mass offer approvals. If this is send through single offer approval there are no errors.
Environment
SAP SucessFactors Recruiting Management
Reproducing the Issue
- Go To Recruiting
- Go To Offers tab
- Select any candidate when the Offer is not Started
- Click on Create Offer
- Edit any of the standalone Offer Approval Field
- System will throw an error "An error occurred while saving your changes. Contact your system administrator”
Cause
This is caused when a standalone field in the Offer Approval template is set as custom="true"
Resolution
The engineers have found the root cause of the issue and the code fix has been merged and will be patch in B2405 release.
Workaround:
Through Provisioning- The standalone field in the Offer Approval template should be set as custom="false"
Through Manage Templates this is not possible.
Keywords
mass offer, bulk, offers, error, popup, standard, approval, process , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Known Error