Symptom
If you delete one piece of information (either phone or mobile number) in SAP Cloud for Customer, this deletion is not executed in SAP Marketing Cloud, which means that it is still available in the contact profile. Only after you delete both (phone and mobile number) in SAP Cloud for Customer, the deletion is triggered and executed in marketing cloud.
Environment
- SAP Cloud for Customer
- SAP Marketing Cloud
Reproducing the Issue
- You add phone and mobile number in SAP Cloud for Customer to an existing business partner.
- Both, the phone and mobile number, are correctly replicated to SAP Marketing Cloud.
- Afterwards, when you delete one information (phone number or mobile number) from SAP Cloud for Customer --> just one of them, not both (in this example we delete the mobile number).
- In SAP Marketing Cloud, the mobile number is still available in the contact profile.
- As soon as we delete both (phone number and mobile number) the deletion is executed as expected in SAP Marketing Cloud.
Cause
You sent from C4C one phone number and communication data telephoneListCompleteTransmissionIndicator flag = false. The phone number is not deleted. This is a standard behaviour.
Resolution
Setting the telephoneListCompleteTransmissionIndicator = true should solve your issue. The problem with telephoneListCompleteTransmissionIndicator set as true is that it will delete all number that are not passed. In case SAP Marketing Cloud only get's Business Partners from SAP Cloud for Customer this is not an issue because there will only be the one from SAP Cloud for Customer anyway. If other sources like s/4 are possible then there could be more than one number and the telephoneListCompleteTransmissionIndicator needs to be false to avoid deleting the extra numbers.
So if you are only replicating from SAP Cloud for Customer to SAP Marketing Cloud then setting this flag as true will solve your issue.
Keywords
telephoneListCompleteTransmissionIndicator, SAP Marketing Cloud, Cloud for Customer, C4C, Business Partner, Mobile, Phone, Number, delete. , KBA , LOD-CRM-INT-YMT , Integration of C4C with Marketing , Problem