SAP Knowledge Base Article - Public

3432202 - "Content" attribute is missing for an autocomplete custom field in the /quotes/{quoteId} RESTful API call response

Symptom

You cannot see the "Content" attribute for autocomplete custom field in the response when using /quotes/{quoteId} REST API endpoint to fetch details of the quote.

In the following image, "TestLim" is an autocomplete custom field which does not have the attribute "Content".

The "DC selection" is a text type custom field which is also blank, but then we can see the "Content" attribute for it without any value in it.

So the expectation is that, even if the auto-complete custom field has no value in it, it should show the "Content" attribute in the response with a blank or null value.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP CPQ SALES CLOUD

Reproducing the Issue

  1. Open postman
  2. Use the following GET API endpoint api/v1/quotes/{quote id} to fetch details of a quote.

Cause

Expected behaviour related to auto-complete custom fields.

Resolution

Only for auto-complete custom fields, null values won't show in the API response.

But for other custom fields, null values show in the response.

Keywords

content field is missing, content element is missing, content field is missing for autocomplete custom field. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions

Attachments

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