SAP Knowledge Base Article - Public

3432505 - eDocument Colombia Cloud Troubleshooting Guide

Symptom

The purpose of this SAP KBA is to provide clear answers to common questions about the eDocument/SAP Document Compliance solution for Colombia. Our goal is to regularly update this documentation with important SAP KBAs, any upcoming changes and address any concerns or problems related to this solution.

Environment

SAP S/4HANA Cloud Public Edition

Cause

Configuration and Maintenance Colombia Channels:

A - SAP Help Document and Reporting Compliance

B – SAP Help BadIs Extending the eDocument Cockpit App with Custom Fields

B - SAP API Hub SAP Document and Reporting Compliance: Electronic Invoicing for Colombia

C - SAP API Hub SAP Document and Reporting Compliance: Electronic Payroll for Colombia 

D - SAP Workzone page 'SAP Document Compliance for Colombia' (Registration for the SAP Workzone page is necessary. Refer to SAP KBA 3608110 - How to join the localization/regional collaboration WorkZone Groups and Community? for further details.

E – SAP Community Portal

F – Initial Configuration eDocument Colombia Cloud Initial Configuration

G - Communication Arrangement Guide: SAP Help Colombia Integration and DRC Integration

H - SAP KBA 2805847 - eDocument Colombia OnPremise Troubleshooting Guide

I – Certificate Issue: The certificate renewal is not a service provided by SAP Product Support. It is recommended to consult SAP KBA 2706322 - What is Support – What is Consulting: Cloud Solutions and seek guidance from your SAP Consultant for further assistance.

Resolution

DIAN Rejection:

"CBB05 and CAV05 Rechazo: La unidad de la cantidad utilizada no existe en la lista de unidades" - Change/Create Sales Order using Unit of Measure accepted by DIAN, for instance BAG. If the material does not have the UoM registered, kindly go to SSCUI Check Units of Measurement and maintain it in Additional Data and check if this data is also available in 'UNIT_OF_MEASURE' Value Mapping.

"CDG01, Rechazo: El código del departamento no coincide con el del municipio" - This and additional errors related to address must be solved by new address solution. Details can be checked at eDocument First Steps guide, but it is important to check the following configurations:

  • City Code checks:
    • Flag "City file active" for the company code at SSCUI 102592 - Set Country-Specific Checks;
    • Change the city in company code address so the city code is updated on ADRC table using SSCUI 105651 - Edit Addresses for Company Codes; Note that it must be the city, other information when changed does not result in a city code update
    • Change something in BP address using BP transaction or "Maintain Business Partner" app (using other apps for customer/vendor is also possible). Note that the same situation from the update of company code address can be applied here. Preferably update the city of the BP address.
      

"CAD02, Rechazo: CustomizationID no indica un valor válido para el tipo de operación"  - Value Mapping 'ACCOUNTING_CUST_ID' must correspond to DIAN's expectation. Please, verify SAP Help Configuring Indicator for Operation Type for Accounting Document (ACCOUNTING_CUST_ID) for further information.

"FAN03 – Payment Method not informed" - It is mandatory to fill the payment method at the moment to create the sales order, data is not modifiable after post the sales order. Go to sales order header, tab accounting and change the payment method field to "T" or "S" (check value mapping for choosing the correct one).

"FAJ18 - Deve contener el literal "es"." - You must change company code language to Spanish. In cloud you can do this by accessing SSCUIs related to company code

"FAB11B and FAB12B - Valor inicial/final del rango de numeración informado no corresponde a un valor." – Kindly review the configuration maintained in Maintain Number Ranges for eDocument Numbering app

"FAD06, Rechazo: Valor del CUFE no está calculado correctamente"- A common root cause for CUFE problems is when the technical key received when the Number Ranges are requested from DIAN, using EDOC_CO_RANGES is incomplete or wrong. If the technical key used by the customer is not valid for register in DIAN, it's necessary access the transaction EDOC_CO_RANGES and request a new range.

"DSAU04 - Base imponible es distinta a la suma de los valores" - This error normally happens for support documents and can occur when tax code V0 is being used in the scenario but it's not filled in the Fix Values tables. In cloud there is a new value mapping FIX_VALUE_REPLACER that can be used to fill those values in fix value TAX_CODE_EXEMPT.

"FAZ04 and FAZ05, Notificación: Modelo/Marca del artículo no fue informada" - 'BrandName' and 'ModelName' must be maintained in 'InvoiceTypeCode =“02” ' for international transaction In Define Fix Value. Kindly refer to SAP KBA 3334585 DIAN Rejection FAZ04 and FAZ05 in eDocument Cockpit app.

"RUT01 Regla: SinCódigo, Notificación: La validación delestado del RUT próximamente estará disponible." - The 'RUT01' message means that you need to review the additional details provided in error and edit it accordantly to what was registered in RUT.

"Regla: 90, Rechazo: Documento procesado anteriormente" - This message means that your document was processed by Tax Authority and cannot be submitted again. 

"DSAJ25b, Rechazo: El contenido de este atributo no corresponde a uno de" - According to DIAN (https://www.dian.gov.co/normatividad/Proyectosnormas/Proyecto%20Resoluci%C3%B3n%20000000%20de%2002-11-2021.pdf - pg 147), the rejection "DSAJ25b" is regarding incorrect or missing data filled in the following node "/Invoice/cac:AccountingSupplierParty/cac:Party/cac:PartyTaxScheme/cbc:CompanyID/@schemeName". The <schemeName> tag will be filled in the ABAP XML for foreign scenarios (vendor different from CO country) only if 'Tax Number Type' is filled on vendor master data or 'Tax Type' is filled for one-time vendor scenarios. Thus, I kindly ask you to review the configuration in Supplier Master Data.

"Regla: CAE04, Rechazo: No fue informado el fin del periodo de facturación que modifica esta nota crédito" and "Regla: CAE02, Rechazo: No fue informado el iniciodel periodo de facturación que modifica esta notacrédito" - kindly refer to SAP KBA 3470268 - CAE02 and CAE04 DIAN Rejection in eDocument Cockpit app

Issues or Errors:

Keywords

S4_PC,S4_1C, EDOC_COCKPIT, colombia, channels, edocument, document, report, CUFE, TAX_TYPE_CUSTOMER, Credit Note, Debit Note, implementation, RUT01, FAZ04, FAZ05, DSAU04, FAD06, FB11B, FB12B, FAJ18, FAN03, MAPPING, CAD02, SSCUI, CDG01, CBB05, CAV05, cae02, cae04, posting date, CERTIFICATE, COMMUNICATION ARRANGEMENT, QR Code, PDF file, URL. , KBA , CA-GTF-CSC-EDO-CO , Colombia , Problem

Product

SAP S/4HANA Cloud Public Edition all versions