SAP Knowledge Base Article - Public

3432839 - Business Catalogs is not visible in IAM Information System app - SAP S/4HANA Cloud Public Edition

Symptom

  • Business Catalogs are available in the system but they are not visible in IAM Information System app.
  • Business Catalogs are only visible through Business Catalogs app.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to "IAM Information System" App.
  2. Select Main Entity as "Business Catalog".
  3. Search for business catalog.
  4. Go to tab Business Catalog - Business Role and Business Catalog - Business User.

Cause

The business catalog is not assigned to any business user or business role.

Resolution

In the IAM Information System application, there are following options to view the data.

  • Business Catalog - Business Role :-> Here, it's possible to fetch data only for the business catalog assigned to business roles.

  • Business Catalog - Business User :-> Similarly, it's possible to fetch data only for the business catalog assigned to business users.

Verify this by following the steps below:

  1. Go to Business Catalogs App
  2. Search for the business catalog
  3. Access the business catalog
  4. Click on More
  5. Notice that it is not used in any Business Roles, Used In Business Roles (0) 

Additionally, check in the IAM Information System app:

  1. Select the Main Entity as Business Catalog
  2. Search for the business catalog
  3. Click on More
  4. Go to the Business Catalog - Scope Items tab and Business Catalog - Business Role Template

It's possible to observe that the business catalog is available in the IAM Information System app.

Assign the business catalog to a business user/business role to view it in the IAM Information system app.

Keywords

IAM Information System, business catalog, Business Catalog - Business Role, Business Catalog - Business User, S4_1C, S4_PC , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions