SAP Knowledge Base Article - Public

3433159 - Pre-paid account transactions are not being picked up by API

Symptom

Financial transactions that are generated and approved for external users using a pre-paid account are not being picked up by the financial transactions API.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Proxy in as External User with Pre Paid Account
  2. Browse categories and search for Class
  3. Book yourself in for Class.  
  4. End Proxy, go back to Learning Admin
  5. Go to Class > Registration Financial Details > Search User
  6. Click View Orders and then the Order Number
  7. In Order Management click Financial Transactions Tab
  8. Posting Status is blank and stays blank after the API has ran.

Cause

For a transaction to be returned, it must have be approved and have a profit centre.

Resolution

We exclude transactions that do not:

  1. Have the status approved
  2. Have a profit centre associated

Once the API is return values through postman, then transaction is marked as "Pending" for Posting Status under Finance --> Financial Transactions. API will not return any values as long as transaction is "Pending". Admin has flexibility to mark it as "Retry" based on business scenario or post new Financial Transactions.

Pls read below link for more details
https://help.sap.com/viewer/5aab9bef78fc4c4fa199c1f7aa142720/2005/en-US/2998b2fd246d402c919b1a163a59002f.html

Keywords

Pre-paid account transactions, API, status approved, profit centre associated, Financial transactions  , KBA , LOD-SF-LMS-COM , Commerce , Problem

Product

SAP SuccessFactors Learning all versions