SAP Knowledge Base Article - Public

3433242 - Warehouse Orders not found during RF Picking - S/4HANA Public Cloud

Symptom

Error message: "Suitable warehouse orders were not found (SCWM/RF_EN056)" while performing picking by WO via the RF path: Outbound process > Picking > Picking by WO, is raised.

 

Environment

S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Log into the Test RF Environment APP;
  2. Click on the "Outbound Process" button;
  3. Select the "Picking" option.
  4. Select the "Picking by WO" option.
  5. Display the WO number;

Error occurs.

Cause

This issue can occur due to missing or inconsistent assignments in the Warehouse Order. Typical root causes identified include:

  1. No queue assigned to the WO:
    A WO without a valid queue cannot be processed in RF. Usually, customizing for queue determination should be checked first. This can also happen if the source storage bins involved do not have proper storage bin sorting, which prevents the system from determining an Activity Area. Without an Activity Area, no queue can be determined. 

  2. Missing WO Resource Type Index entry:
    Even if a queue is assigned, the WO may lack a valid Resource Type Index entry. This entry is required for RF processing. It may be missing if system settings (e.g., operating environment of the queue) were changed after the WO was created. 

Resolution

To resolve the issue, validate the following:

  1. Check Queue Assignment

    1. Open the Warehouse Monitor app.

    2. Navigate to Resource Management > Queue > Warehouse Order.

    3. Confirm that the WO has a valid queue assigned.

    4. If no queue is found:

      1. Check customizing for queue determination in SSC-UI Define Queues. This should include definition of queues and their relevancy for RF via the Operation Environment, queue determination, and queue access sequence.

      2. Evaluate the warehouse task log and check entries on queue determination. You can access this log in the Warehouse Monitor app by drilling down to the WTs of the WO in question. Via the More Methods button you can execute the Display WT Log action.

      3. Verify the storage bin sorting and Activity Area setup for the relevant storage bins, and recreate the WO.

  2. Check WO Resource Type Index Entries

    1. Open the Warehouse Monitor app.
    2. Navigate to Resource Management > Queue > Warehouse Order

    3. From there, you can drill down to the WO – Resource Type Index. 
    4. Ensure that valid entries exist. If missing, this could indicate that the WO was created under inconsistent queue settings, e.g., without Operating Environment 3 (RF; Resource Management Active) setting, or it was changed afterward the WO was created. Due to this, no WO Resource Type Index entry got created. 

    5. In such cases, recreate the WO so that proper entries are generated.

  3. Re-test in RF

    • Once the WO has a valid queue and a Resource Type Index, it can be processed in RF without encountering a stuck error message that blocks processing. 

Additional Information

If the issue persists after verifying both queue and Resource Type Index assignments, review the configuration of Activity Areas, Queue determination, and Resource Type definitions to ensure consistency.

Keywords

s/4hana cloud, EWM, WM, SCWM/RF_EN056, SCWM/RF_EN 056, suitable warehouse orders were not found, Warehouse Order, WO. , KBA , SCM-EWM-RF-PCK-2CL , Picking (Public Cloud) , Known Error

Product

SAP S/4HANA Cloud Public Edition all versions