SAP Knowledge Base Article - Public

3433596 - SAP Marketing Cloud Segmentation - Geolocation filters not working

Symptom

You are using the geolocation attributes, longitude and latitude, in segmentation to filter on contacts, the preview and the filter give strange results.

Environment

SAP Marketing Cloud

Reproducing the Issue

  1. create a new segmentation model in SAP Marketing
  2. consume the segmentation attribute latitude to create a segment
  3. observe unexpected results

Cause

Geolocation attributes are defined as a pair of longitude and latitude. The longitude and latitude must be imported on contact level as there is no automated address to geolocation mapping existing. Further the usage of those attributes requires a certain configuration set up to work - if this is not set up properly, segmentation on geolocation data does not work.

Resolution

  • The contact must have the geolocation data imported as documented in the following KBA:
    3433596 - SAP Marketing Cloud Segmentation - Geolocation filters not working

  • In the segmentation configuration geolocation attributes are defined via the semantic type 'Geo Point' and 'Geo Point without (0,0)'. The longitude requires the latitude as dependent attribute, and vice versa. The attribute longitude is considered as leading attribute, which is set to visible, whereas the latitude is set to invisible.
    The following shows the correct set up based on the contact attributes ic_longitude and ic_latitude
  • longitude
  • latitude

See Also

Please also refer to the online help:

Keywords

Segmentation, Geolocation data, Longitude, Latitude, Geo Point
Segmentierung, Geolokationsdaten, Längengrad, Breitengrad, Geographischer Punkt
Segmentation, Donnée de géolocalisation, Longitude, Latitude, Point géographique , KBA , CEC-MKT-SEG , Segmentation , Problem

Product

SAP S/4HANA Cloud Public Edition all versions

Attachments

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