SAP Knowledge Base Article - Public

3433676 - The Error "554 5.0.0 Message rejected: Email address is not verified" is Displayed for An E-mail Output

Symptom

When outputting documents via e-mail in SAP Business ByDesign, the status of the output shows an error, and raises the following message:

"554 5.0.0 Message rejected: Email address is not verified. The following identities failed the check in region X: Y" (where X represents a datacenter region, and Y represents the sender e-mail address)

Environment

SAP Business ByDesign

Reproducing the Issue

This issue can happen in any e-mail sent through the SAP Business ByDesign system. A Purchase Order document will be used in the following example: 

  1. Go to the Purchase Requests and Orders work center.
  2. Enter the Purchase Orders view.
  3. Open a Purchase Order ABC (where ABC refers to the Purchase Order ID).
  4. Click on the View All button.
  5. Navigate to the Output History tab.

The output document is displayed with the status as Error and the following message is displayed in the Error Message field.

"554 5.0.0 Message rejected: Email address is not verified. The following identities failed the check in region X: Y"

Cause

The domain being used in the sender e-mail address has not been activated for DKIM. This is a mandatory setup for e-mail domains used in SAP Business ByDesign systems.

Resolution

To activate DKIM for the email domain, open a SAP case and request the DKIM activation for the domain of the email that is sending the output document with error.

See Also

Refer to the below KBA for the DKIM activation process:

KBA 2937666 - DKIM Key Activation for sending the Business Emails in SAP Business ByDesign (ByD)

Keywords

email, queue, AWS, DKIM, Output History, domain  , KBA , AP-RC-OUT , Output Management , Problem

Product

SAP Business ByDesign all versions