SAP Knowledge Base Article - Public

3433733 - The Error "Object currently locked by XXX; try again later" is Displayed for Invoice Requests

Symptom

You notice that a Outbound Delivery Invoice Request is currently locked for invoicing after a Invoice Run is performed in the system. When opening the Outbound Delivery Invoice Request the error "Object currently locked by XXX; try again later" is displayed in the UI.

(where XXX represents the user ID)

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing Work Center.
  2. Go to the Invoice Request View.
  3. Filter All Invoice Requests.
  4. In the search field, search for the Outbound Delivery Invoice Request ABC (where ABC represents the Outbound Delivery Invoice Request ID).
  5. Mark the Outbound Delivery Invoice Request ABC.
  6. Select Edit button.

The error "Object currently locked by XXX; try again later'" is displayed in the UI.

Cause

Two or more Invoice Runs have been scheduled to be executed by the user XXX. This invoice runs are sometimes overlapping which is causing both background jobs to try to access a document at the same time causing a lock error for the document.

This can be check by following the below steps:

  1. Go to the Application and User Management Work Center.
  2. Select the Background Jobs View.
  3. Select the Advance Filter.
  4. In the Responsible User field, enter the User ID XXX.

The Invoice Run/Background jobs scheduled for the user XXX will be displayed.

You can see by the recurrence period that at some moment of the day the Invoice Runs are occuring parallel execution which is causing the Outbound Delivery Invoice Request to be locked by the user XXX.

Resolution

We kindly recommend to rearrange the recurrence schedule of the Invoice Runs for the user XXX in order to avoid their parallel execution and therefore avoid the lock error for the invoice requests.

In addtion, if Invoice Requests documents are already with the error "Object currently locked by XXX,  try again later" then we ask you to open a case with approval to remove the locks of the invoice requests documents through the backend.

See Also

Please also kindly check the following documentation regarding lock errors for Sales documents in the system:

KBA 2733352 - You Receive Error Message "Operation not possible; document locked by ZZZ"

KBA 3319137 - Sales Order is Frequently Locked and Updated

Keywords

outbound delivery invoice request, invoice request, background jobs, object currently locked by, try again later , KBA , SRD-CRM-INV , Customer Invoicing , AP-CI-CI , Customer Invoice , How To

Product

SAP Business ByDesign all versions