SAP Knowledge Base Article - Public

3433997 - User Cannot Edit Certain Job Requisition Field Despite the Correct Permissions - Recruiting Management

Symptom

User is not able to edit certain job requisition field despite the correct permissions.

Environment

SAP SuccessFactors Recruiting Management

Cause

The field cannot be displayed properly due to syntax errors (extra line breaks or spaces) in the field definition.

This happens when the job requisition XML template is imported from Provisioning with incorrect XML syntax.

(For SAP Support: see internal memo)

Resolution

Please correct the syntax in the field definition.

For example, there may be extra line breaks or spaces in the field label like below:

  <field-definition id="examplefield" type="text" required="true" custom="true">
  <field-label><![CDATA[
Example Text
]]></field-label>
  <field-description><![CDATA[Example Text]]></field-description>
  </field-definition>

Correct field definition:

  <field-definition id="examplefield" type="text" required="true" custom="true">
  <field-label><![CDATA[Example Text]]></field-label>
  <field-description><![CDATA[Example Text]]></field-description>
  </field-definition>

NOTE: When there is a syntax error, it is likely that the field cannot be edited using the Manage Templates tool. Please ask the implementation partner to modify the job requisition template via Provisioning > Import/Update/Export Job Requisition Template.

If the problem you are facing does not match this situation, please refer to KBAs in the See Also section or raise a Support ticket for further assistance.

See Also

Keywords

RCM, Job Requisition, field, write, permission, edit, invisible , KBA , LOD-SF-RCM-JOB , Job Postings & Requisitions , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions