Symptom
When you are replicating business partners to C4C, you encounter an error "Business partner 1234 is not an employee" in Web Service Message Monitoring for the service interface BusinessPartnerReplicationIn (where 1234 is the business partner's Internal ID).
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query "All".
- Search for message ID with error "Business partner 1234 is not an employee".
Cause
The incoming payload has the following node (where XYZ means the code ID and 9876 is the business partner External ID):
<PartnerFunctions>
<PartyRoleCode>XYZ</PartyRoleCode>
<PartyInternalID>9876</PartyInternalID>
...
</PartnerFunctions>
However, field PartyRoleCode in C4C is reserved for Account-to-Employee relationships.
Resolution
In order to solve your issue, the field PartyRoleCode from S4 should be mapped to BusinessPartnerRelationshipCategoryCode in CPI.
The standard iflow mappings and attributes are present in our documentation. It shows exactly how the mapping should be done. You can find it on SAP API Hub Replicate Business Partner from SAP Business Suite.
See Also
Keywords
C4C, Code List Mapping, BusinessPartnerReplicationIn, "Business partner 1234 is not an employee", BusinessPartnerRelationshipCategoryCode, PartyRoleCode , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To