SAP Knowledge Base Article - Public

3434512 - Source Settings Not Working In SAP Service Cloud Version 2

Symptom

In Cases, all values are shown in Source field dropdown irrespective of the setup maintained in Source Settings.

Environment

SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to User Menu.
  2. Go to Settings.
  3. Search for Cases.
  4. Select Source Settings.
  5. Click on the Edit button next to Source ABC (where ABC is a Source Type).
  6. Toggle the Source Visible button to hide the Source Type and click on Save.
  7. From Navigation Panel, go to Cases.
  8. Click on the plus (+) icon to create New Case.
  9. Go to the Source field and notice that in the dropdown Source Type ABC is visible.

Cause

Currently, the Source Settings is applicable for the 'Source Code (Code)' field and not the 'Source' field. Therefore, if Source field is added instead of Source Code (Code) field in Create Case quick view via Adaptation, then all the Source Types will be shown in the Source field dropdown.

Resolution

Follow the below steps to ensure that Source Code (Code) field is marked as visible in the Create Case quick view:

  1. Go to User Menu.
  2. Click on Start Adaptation.
  3. Click on the plus (+) icon for the Create Case quick view pop-up.
  4. Click on the pencil icon to edit the fields shown in Create Case quick view.
  5. Search for the Source Code (Code) field and mark it as 'Visible'.
  6. Click on Apply.
  7. To close the Adaptation Mode, click on End Session.

Keywords

Source, Source Code, Create Case , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Service Cloud Version 2 all versions