Symptom
The placeholder used in an E-mail template is not Populated/Replaced with the Desired Value.
Environment
SAP Service Cloud Version 2
Reproducing the Issue
- Navigate to Cases work center.
- Open any case.
- Click Send Email.
- Click on Add Templates and choose a Template.
- Click Email Preview.
- Notice that the template is displayed, but the placeholders are not replaced with the expected values.
Cause
The attributes used in e-mail template as placeholders (for e.g "{{registeredProducts.displayId}}" or "functionalLocations.displayId}}") are of type Array.
Resolution
Indexes need to be used along with placeholder names to fetch the desired values for the attributes of type Array. Some examples include "{{functionalLocations.[0].displayId}}" , "{{registeredProducts.[0].displayId}}" etc.
See Also
Keywords
Placeholder, Templates, Array, E-mail , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem