SAP Knowledge Base Article - Public

3434774 - Placeholder in Email Template is not populated with Desired Value

Symptom

The placeholder used in an E-mail template is not Populated/Replaced with the Desired Value.

Environment

SAP Service Cloud Version 2

Reproducing the Issue

  1. Navigate to Cases work center.
  2. Open any case.
  3. Click Send Email.
  4. Click on Add Templates and choose a Template.
  5. Click Email Preview.
  6. Notice that the template is displayed, but the placeholders are not replaced with the expected values.

Cause

The attributes used in e-mail template as placeholders (for e.g "{{registeredProducts.displayId}}" or "functionalLocations.displayId}}") are of type Array.

Resolution

Indexes need to be used along with placeholder names to fetch the desired values for the attributes of type Array. Some examples include "{{functionalLocations.[0].displayId}}" , "{{registeredProducts.[0].displayId}}" etc.

See Also

3347427 - Unable to See Text Content Added to Email Body when Using Templates in Cases

Keywords

Placeholder, Templates, Array, E-mail , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem

Product

SAP Service Cloud Version 2 all versions