SAP Knowledge Base Article - Public

3435105 - Notification Not Received For Failed Workflow

Symptom

Notification for the failed workflow is not received.



Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: Configuration to receive workflow notification is maintained for Business Object when workflow is failed.

  1. Navigate to the service work centre.
  2. Go to the Tickets work centre view.
  3. Search and open any ticket.
  4. Execute steps towards the defined workflow.
  5. Go to the Workflow facet.
  6. Log for the failed workflow appears.
  7. Notification towards failed workflow is defined in the following configuration.

Issue: Notification of the failure of workflow is not received by the user who is defined. Execute the following steps to check or assign the business users: -

  1. Go to the administrator work center.
  2. Go to the Workflow Rule work center view.
  3. Select the workflow row.
  4. Click on More.
  5. Select the option "Workflow settings".
  6. Click on the "Notification On Failed Rules" hyperlink.
  7. Click on Add.
  8. From the Value Help, select the business users to assign the user who receives the notification.
  9. Save.

Cause

Cache was not generated for notification type WKF_GEN_FAILED_RULE_NOTIF, due to which the system did not generate any notification.

 

Resolution

Disabling and enabling the following scoping question will generate the cache, which leads to receipt of notification for a failed workflow rule. 

Execute the following steps towards the associated scoping question.

  1. Go to Communication and Information Exchange.
  2. Go to Business Process Management.
  3. Go to Business Task Management.
  4. Scoping question: "Do you want to switch off Failed Workflow Rule Notification for Key Users?" 
  5. Disable the question and save.
  6. Enable the question and save.
  7. This generates cache in the backend.

Now, the cache is generated, and notifications for failed workflow rules are received.

Note: 

  1. This feature is available for all workflows if the configuration is maintained.
  2. There will be a delay in notification received towards failure of workflow because the job runs every 1 hour.

Keywords

Failed workflow, notifications, Business Users, Not Received , KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications 2402