Symptom
You are using a Free Text Item in customer invoice and the system is unable to determine whether the item is Product or a Service.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Customer Invoicing work center.
- View: Invoice Documents.
- Search and edit Invoice ID ABC (ABC represents the ID of Invoice document).
- Navigate to Items tab.
- You can see HSN code is already assigned to JSON structure for line item XX (XX is line item number).
Cause
The system is considering the Customer Invoice Item as a Product and not as a service. That's why we have tag "IsServc": "N" (Not a service) in the JSON file.
As the Customer Invoice Item is a Free Text Item, the system can't determine whether it is a product or a Service.
Resolution
We recommend you to kindly create a service explicitly for particular item, maintain the HSN code there and use that in the Customer Invoice Item.
Please create the Required Service using 'New Service' option in the 'Product Data' work center and then assign the HSN/SAC code in field 'Accounting Code of the Service' in the General Tab.
Product Data --> New Service --> View All --> General Tab --> Accounting Code of the Service
Then only the Item will be considered as Service for Customer Invoice and correct HSN/SAC code will be fetched and validated in the IRN portal.
Keywords