Symptom
When replicating Business Partners from an external system to C4C under service interface BusinessPartnerERPAddressReplicationIn in a standard integration scenario, the message fails with error "Business partner category does not exist; use 1 or 2".
Environment
- SAP Cloud for Customer
- SAP ERP
- SAP S/4HANA
Reproducing the Issue
- Go to the Administrator work center.
- Open the Web Service Message Monitoring.
- Filter the incoming messages with service interface "BusinessPartnerERPAddressReplicationIn".
- See the error details - "Business partner category does not exist; use 1 or 2".
Cause
The error message occurs due to missing <CategoryCode> in the incoming payload. In C4C, <CategoryCode> can have the following values:
- 1: Natural Person in ERP, Individual Customer in C4C;
- 2: Customer in C4C.
Resolution
Either this is not being sent from the external system or there is something wrong with the mapping. Kindly check the source sender system message and middleware mapping.
Keywords
Cloud for Customer; C4C; ECC; S4; CategoryCode; BusinessPartnerERPAddressReplicationIn; Business Partner Category; Business Partner. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To