SAP Knowledge Base Article - Public

3435568 - Error Message SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_HOST_UNKNOWN") for Outbound Service Interfaces

Symptom

You are replicating business objects from C4C to external system and you are facing the error message  "Unknown host name (ICM_HTTP_HOST_UNKNOWN)" from the related service interface.

Environment

SAP Cloud for Customer

Reproducing the Issue

In this document, we are using the Accounts to exemplify the issue, but it may be applied for other C4C business objects outbound replication is allowed.

  1. Go to the Customer work center.
  2. Go to the Accounts work view.
  3. Open, edit and save the Account 123 (where 123 means the Account ID).
  4. Go to the Administrator work center.
  5. Go to the General Setting work center view.
  6. Open the Web Service Message Monitoring under System Administration.
  7. Select query Erroneous.
  8. Search for message with Error Text "SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_HOST_UNKNOWN")".

Cause

When you check the Error Log of the message (View > Error Log) you verify:

  <TRANSPORT_INFO>
    <AUTHENTICATION_METHOD>sapsp:HTTPX509</AUTHENTICATION_METHOD>
    <AUTH_METHOD_X509_KEYSTORE_VIEW>DFAULT</AUTH_METHOD_X509_KEYSTORE_VIEW>
    <TARGET_HOST_NAME>HOST_NAME</TARGET_HOST_NAME>
    <TARGET_PORT_NUMBER>443</TARGET_PORT_NUMBER>
    <TARGET_PATH>TARGET_PATH</TARGET_PATH>
    <HTTP_TIMEOUT>0</HTTP_TIMEOUT>
  </TRANSPORT_INFO>

And the data maintained in the HOST_NAME or TARGET_PATH is wrongly defined according to the information maintained in the iflow.

Resolution

To correct the error you may verify and correct the Target Path in the communication arrangement on C4C and maintain the data as per the iflow used for the integration. You can check the following steps for doing so:

  1. Go to the Administrator work center.
  2. Go to the General Setting work center view.
  3. Go to the Communication Arrangements under Integration session.
  4. Search and open the affected Communication Arrangement.
  5. Click on View All.
  6. Go to the Technical Data facet.
  7. Click on Edit Advanced Settings button.
  8. Go to the Outbound tab.
  9. Under Details, set the information accordingly.

Keywords

KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications all versions