Symptom
When using Integration Center to report overall rating comments value, special characters (HTML tags) sometimes appear.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Integration center
- Create New Scheduled CSV File Output Integration
- Search "InterviewOverallAssessment" Entity
- Select "comment" property to report
- View some values in comment contains HTML tags
Cause
Overall rating comments field in Interview center is a richtext field. If formatting characters are written into overall rating comments, then will cause this issue.
Resolution
If want to avoid HTML tags appear in Integration Center report, be sure to edit the comments as follows:
- Guaranteed manually entry.
- Do not copy anything and paste it into the comment.
- Do not break up characters into paragraphs or lines.
- You can use spaces, upper and lower case letters, numbers, punctuation, ...? @#$, etc.
If the comment already contains formatting characters. You need to delete the existing comment and save it, then go back to the page to edit the comment as described above and save it again .
In order to monitor the input values in the comment box timely, you can use DevTools to see the whole characters and view if have HTML tags.
See Also
3156441 - Interview Result Comments Pop-Up Window showing special characters
3062622 - Interview Central - 4000 Character Limit for Comment Box - Recruiting Management
Keywords
HTML, tag, format, formatting, special, character, integration center, report, comments, overall rating comments, IVW, interview center, InterviewOverallAssessment , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem