Symptom
When attempting to re-trigger the I-9 Process Flow user receives an error.
Error: "The previous sections of Form I-9 are incomplete for the selected user. Please complete them to proceed.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to BPE Monitor Process.
- In the variable field search for the candidate using "onboardingProcessId=" or "userSysId=".
- Confirm if I-9 process is complete for the candidate.
- See that Section 2 is not completed/unfinished.
Cause
Section 2 was not completed.
Resolution
Complete Section 2 for the candidate then the process flow for the candidate can be restarted without the error.
- Log onto BizX on the homepage.
- Click on I-9 Compliance Tile.
- Complete Section 2.
Keywords
I-9, I9, Process flows, I-9 Process flows, I9 Process flows, SuccessFactors, Onboarding, I9 error , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem