Symptom
You are replicating employees from SAP S4HANA / SAP SF Employee Central / SAP ERP to SAP Sales & Service Cloud v2 and the replication fails with error stating the Employee already exist.
Environment
SAP Sales & Service Cloud V2 Integration with SAP S4HANA
SAP Sales & Service Cloud V2 Integration with SAP ERP
SAP Sales & Service Cloud V2 Integration with SAP Successfactors Employee Central
Reproducing the Issue
- Go to Webservice Monitoring
- Check the failed employee replication with error "Employee ID XYZ already exists"
Cause
Employee with same ID already exists in the system, created manually or imported via some other source
Resolution
When an employee is replicated from S4HANA/ERP/EC to V2 system , we send the Employee ID as both "displayId"(ID from External System) & "receiverDisplayId"(Internal ID of V2). Employees Internal ID & External ID should be same in principle. Then if an employee with same Internal ID exists , system will trigger this error message.
To fix this issue, create the ID Mapping manually and reprocess the failed message.
Keywords
KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem