Symptom
In Campaigns, E-mail template created in the system is not found in Template Selection Quick View pop-up when an Object is selected in Add Template.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to User Menu and click on Settings.
- Under All Settings, search for Emails.
- Navigate to Templates.
- Create a new Template with Template Type as Campaign Template and Communication Type as newsletters.
- Fill all mandatory fields and click on Save.
- From the Navigation Menu, go to Campaigns.
- Open a Campaign which is in 'In Preparation' Status.
- Under Campaign Details, click on Send Email.
- Click on Add Template action and select an Object.
- Click on the object selected and notice that the newly created template is not available in the Template Selection Quick View pop-up.
Cause
Newsletter campaign templates are object independent since there is no placeholder replacement expected in a newsletter scenario.
Resolution
This is the current expected behavior of the system. Templates with Communication Type newsletters are not object based. Therefore, they would not be available for Object Based Template selection.
Keywords
Templates, Communication Type, Campaigns, newsletter , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-CAM , Campaign for SAP Sales/Service Cloud , Problem